Fuel pump relay may cause engine no start or stalling.

MY RECOMMENDED TOOLS-
1.BLUETOOTH SCANNER-amzn.to/2Y52H6P
2.OK SCAN TOOL-amzn.to/2W3qIJu
3.GREAT SCANNER ALL SYSTEMS-amzn.to/2OaAjeN
4.IMPACT GUN-amzn.to/2Oa2aMi
5.BATTERY JUMP START TOOL-amzn.to/2Fa5dQt
6-PROFESSIONAL SCAN TOOL-amzn.to/2W1bFQo
7-SOCKET SET GREAT PRICE-amzn.to/2THQxCk
8-WRATCHET WRENCH SET-amzn.to/2FdnVGM

LINK TO MY AMAZON STORE www.amazon.com/shop/influencer-d0aff233?ref=ac_inf_hm_vp

link to replace spark plugs and ignition coil replacement-automobilrevue.net/v/Qkwxak4xZEZoQ2M

link to clean throttlebody-automobilrevue.net/v/UUlkQ0R3ZXk0eDQ

LINK TO BUY MERCH SUPPORT THE CHANNEL-teespring.com/stores/nyc-mods-forever

LINK TO BUY SCANNER-www.amazon.com/dp/B07CSMJJK9/?ref=exp_influencer-d0aff233_lv_dp_vv_mw

subscribe to my channel HIT THE SUBSCRIBE BUTTON-www.youtube.com/user/fabolousg4ever/about?view_as=subscriber

subscribe to my

instagram-www.instagram.com/fabolousg4ever/

subscribe to my facebook-www.facebook.com/profile.php?id=100015510723364

subscribe to my twitter-mobile.twitter.com/infamousg4ever/tweets

DON'T FORGET TO LIKE SHARE AND SUBSCRIBE

Fabolousg4ever is a participant in the Amazon Influencer Program.
if isnt replaced in recall
Mitsubishi relay faulty
REPLACEMENT part denso relay
#p/n 39794-sda-305

Comments

    • MODS FOREVER
      MODS FOREVER

      MY RECOMMENDED TOOLS-
      1.BLUETOOTH SCANNER-https://amzn.to/2Y52H6P
      2.OK SCAN TOOL-https://amzn.to/2W3qIJu
      3.GREAT SCANNER ALL SYSTEMS-https://amzn.to/2OaAjeN
      4.IMPACT GUN-https://amzn.to/2Oa2aMi
      5.BATTERY JUMP START TOOL-https://amzn.to/2Fa5dQt
      6-PROFESSIONAL SCAN TOOL-https://amzn.to/2W1bFQo
      7-SOCKET SET GREAT PRICE-https://amzn.to/2THQxCk
      8-WRATCHET WRENCH SET-https://amzn.to/2FdnVGM

      LINK TO MY AMAZON STORE https://www.amazon.com/shop/influencer-d0aff233?ref=ac_inf_hm_vp

      link to replace spark plugs and ignition coil replacement-https://youtu.be/BL1jN1dFhCc

      link to clean throttlebody-https://youtu.be/QIdCDwey4x4

      LINK TO BUY MERCH SUPPORT THE CHANNEL-https://teespring.com/stores/nyc-mods-forever

      LINK TO BUY SCANNER-https://www.amazon.com/dp/B07CSMJJK9/?ref=exp_influencer-d0aff233_lv_dp_vv_mw

      subscribe to my channel HIT THE SUBSCRIBE BUTTON-https://www.youtube.com/user/fabolousg4ever/about?view_as=subscriber

      subscribe to my

      instagram-https://www.instagram.com/fabolousg4ever/

      subscribe to my facebook-https://www.facebook.com/profile.php?id=100015510723364

      subscribe to my twitter-https://mobile.twitter.com/infamousg4ever/tweets

      DON'T FORGET TO LIKE SHARE AND SUBSCRIBE

      Fabolousg4ever is a participant in the Amazon Influencer Program.

      about 1 month ago
    • Luis Santos
      Luis Santos

      Wassup man I changed the main relay assembly it's that the same ? I have a 2002 acura tl type s

      about 15 days ago
    • MODS FOREVER
      MODS FOREVER In reply to Luis Santos

      not 100 percent sure

      about 4 days ago
    • MJAdetroit
      MJAdetroit

      @1:28 LOL@'meetsabeeshoo relay' ....just playin meng

      about 3 months ago
    • cameron haywood
      cameron haywood

      Hey bro I found that MITSUBA relay in my 2006 Acura TL. It sometimes has trouble starting. Could the relay be replaced for free by a recall? I checked to see if my car had any recalls on the Acura site and it said I didn't have any. Thank you for you response man.

      about 3 months ago
    • jon doe
      jon doe In reply to cameron haywood

      You can find relay cheap on eBay. Just got one for my 99 Acura TL for like $20

      about 1 month ago
    • No Comps
      No Comps

      This worked awesome! BEST demo of how to fix this on YouTube, hands down!!!

      about 6 months ago
    • MODS FOREVER
      MODS FOREVER In reply to No Comps

      You welcome glad to help

      about 5 months ago
    • No Comps
      No Comps

      I just went to Auto Zone to get a replacement and it was MITSUBA out of the box!!!

      about 6 months ago
    • MODS FOREVER
      MODS FOREVER In reply to No Comps

      Oh shouldn't it be denso

      about 5 months ago
    • No Comps
      No Comps In reply to No Comps

      Duralast part brand

      about 6 months ago
    • roger thornton
      roger thornton

      Thank u so very much every ones carpet is dirty don’t worry about that but my Acura starts good it had stuttered 2 times I though it was the fuel pump.

      about 8 months ago
    • roger thornton
      roger thornton

      Thank u sir I didn’t know what the hell was happing to my 2002 Acura I keep it up I have had it for 12 years thank u so very much.

      about 8 months ago
    • 1trucavalier
      1trucavalier

      Just lioked at mine and sure enuff MITSUBA made in vietnam! Thanks a million man!

      about 8 months ago
    • MODS FOREVER
      MODS FOREVER In reply to 1trucavalier

      1trucavalier no problem

      about 8 months ago
    • EMCFilmz
      EMCFilmz

      Is the fuel pump relay the same as the A/F Relay ??? My mechanic wrote down a/f relay but I search it at advanced with no luck

      about 10 months ago
    • Kuuryo
      Kuuryo In reply to EMCFilmz

      Bank 2 sensor 2 is going to be downstream. A/F relay sounds like he didn't know exactly what it was (maybe Pgm/FI or MAIN relay) and took a wild stab in the dark based on the relays function.

      about 1 month ago
    • EMCFilmz
      EMCFilmz In reply to EMCFilmz

      fabolousg4ever please and thank you also bank 2 sensor 2 in terms of upstream or downstream front or rear which one is it ?

      about 10 months ago
    • MODS FOREVER
      MODS FOREVER In reply to EMCFilmz

      EMCFilmz air fuel relay IDK Imma do a little research I will get back to u

      about 10 months ago
    • mckoy lach
      mckoy lach

      I have an 02 Acura TL type S,where is the fuel pump relay or main relay located? Or is it a one relay,together?

      about 11 months ago
    • moua kong
      moua kong

      Could this cause the car to crank but not start? My fuel pump primes tho. 04 tl 6spd. Thanks for the videos!

      about 1 year ago
    • len rodriguez
      len rodriguez In reply to moua kong

      For me was the relay

      about 3 months ago
    • 209paulr
      209paulr In reply to moua kong

      moua kong did you figure out why your car didn't started?

      about 8 months ago
    • MODS FOREVER
      MODS FOREVER In reply to moua kong

      moua kong no prob

      about 8 months ago
    • Derrick Carter
      Derrick Carter

      Good article as always my passenger side seat doesn't get warm could this be a fuse maybe???

      about 1 year ago
    • Kuuryo
      Kuuryo In reply to Derrick Carter

      Seat heating elements go bad all the time. They're basically a thin copper wire that snakes around the surface of your seat, bending and flexing the wire as people sit down, shift in the seat, and get out of the car wears them out and wires break. The seat cover probably needs to be removed and heating element replaced.

      And no, the light in some vehicles only indicates that you've turned the switch on, it does not necessarily indicate whether or not the heater is actually functioning.

      I hate replacing those things.

      about 1 month ago
    • John Rutherford
      John Rutherford In reply to Derrick Carter

      Derrick Carter my 01 Acura passenger seat takes forEVER to heat up. Driver side no problem. The heating element is probably going out because if it was a blown fuse it wouldn’t come on at all. Plus that light that tells you when it’s on high or low wouldn’t come on.

      Only thing I can say would be to check the resistance with a voltmeter on the working side at the plug under the seat and do the same thing on the passenger side. Too much resistance means either a short or a wire somewhere is going bad.

      about 1 month ago
    • Ryan Rendon
      Ryan Rendon In reply to Derrick Carter

      Derrick Carter same mine isn’t working either

      about 1 year ago
    • Nuel P.R Bau
      Nuel P.R Bau

      One question i have an acura tl 2004 automatic and when the car is cold he runs and work well but when tbe car is warm he stop runing and go to false neutral one mechanic told me that he saw that in another acura and was the body valve so i should replace the transmission or repair the body valve???any sugestion please??

      about 1 year ago
    • Mas Doe
      Mas Doe In reply to Nuel P.R Bau

      Depending on how its shifting

      about 6 months ago
    • MODS FOREVER
      MODS FOREVER In reply to Nuel P.R Bau

      +Emma Bullying ostia it could be the transmission neutral safteyswitch did you scan the transmission for codes.

      about 1 year ago