How to fix reduced engine power and service traction control system on your vehicle. If your car displays the warning Reduced Engine Power, here is the fix!

Comments

    • Luis Ortiz
      Luis Ortiz

      thank you for your contribuition for all the people that have the same issue but to be honest each case is different is no t always the same, let me tell you my experience, l had issue with my differential and i spend a lot of money with 3 difents mechanic that just want to steal my money because one said that was the cv joint other that diffential but, at this time i dont know exactly what was the problem, the point here is that finaly i fixed the diferential problem but the engine power is reduce light sudenly came out and the mechanic thief said that was the throle body, but finaly i found a honest mechanic and was something about the gas sensor, to end this tip to my experience not always is the throttle body think more the two time to move at your throttle body because is really delicated

      about 3 hours ago
    • Nature Restored
      Nature Restored

      4:44 LOL Keyboard Warriors !! 🤪

      about 19 days ago
    • Chris O’Steen
      Chris O’Steen

      Having the same problem with my 09 malib 2.4 ecotec .. iI’ve replaced everything noted in the comments and video still no luck but the car does run ok every now and again.. so when i get it running right i give it the wiggle wire test and every time i touch the under hood box it starts spudering and goes in reduced engine power , ive had the whole fuse box replaced and still doin the exact same thing.. any pointers would be greatly appreciated.. frustrating is not the word right now

      about 1 month ago
    • Porchia Dillihuny
      Porchia Dillihuny

      Appreciate the help easy job especially the steps you took can save me A couple extra 100 bucks

      about 1 month ago
    • Kyle Walker
      Kyle Walker

      Thank you for the video would you recommend just replacing the entire throttle body my car is doing the exact same thing mines a 2006

      about 2 months ago
    • Kyle Walker
      Kyle Walker In reply to Kyle Walker

      +ts6034 well here's the problem I replace the brand new throttle body and the codes came back on to get to my mechanic and he said if the voltage is it regulating right and what he means by that is there's like a cut wire or a broke wire somewhere so yeah I could possibly be in the wire harness going to the throttle body but the throttle body with nasty it needed to be replaced

      about 2 months ago
    • ts6034
      ts6034 In reply to Kyle Walker

      That would be the fastest and easiest route if the fault is the throttle body. Sometimes it’s the pedal sensor but the throttle body is the most common. Also, I’ve ran into a few that ended up being the wire harness that plugs into the throttle body.

      about 2 months ago
    • Leafrench1
      Leafrench1

      What was the band name of that scanner? I didn't want to watch the whole video again.

      about 2 months ago
    • ceeztha dabgod
      ceeztha dabgod

      Thanks for the help going see if this work

      about 2 months ago
    • Rudy Romero
      Rudy Romero

      You are awesome!! Thank you for this!!!!

      about 2 months ago
    • ts6034
      ts6034 In reply to Rudy Romero

      Thank you!

      about 2 months ago
    • Eddie Gebhard
      Eddie Gebhard

      Got this same issue with my GMC Acadia 2007, its totally random. It mostly happens when I start my vehicle on cold morning and let it pre-heat. If I just get in and get going with cold engine it usually does not happen.

      about 2 months ago
    • Christina Vititoe
      Christina Vititoe

      I have a 2011 Chevy Cruze. Same problem with engine power reduced. Just got my throttle body ($158) later. Getting ready to go put it in with my brother. Will let you know how it went. WISH US LUCK!!

      about 2 months ago
    • Nathan Flores
      Nathan Flores

      Does this work for g3(

      about 2 months ago
    • Nathan Flores
      Nathan Flores In reply to Nathan Flores

      G35

      about 2 months ago
    • Ahmad Alirani
      Ahmad Alirani

      Amazing video thank you it really helped me !

      about 3 months ago
    • Albert Perez
      Albert Perez

      Your an idiot to hit a throttle body and a new tps with a hammer to set the retainer clips.

      about 3 months ago
    • ts6034
      ts6034 In reply to Albert Perez

      *you're

      about 3 months ago
    • Ronald Neal
      Ronald Neal

      Good job

      about 3 months ago
    • Sam Rogers
      Sam Rogers

      TPS sensor also on another video a man diagnosed it and saw where 4 electrodes are fused together

      about 3 months ago
    • Melissa Ziegler
      Melissa Ziegler

      My daughter's 08 impala, the battery went dead in our polar vortex weather. We put new battery in started right up, bit now it's doing this same thing. It did sit for 4 days in sub zero weather dead before we could get to her car. Question: would the cold weather and dead battery blow out this sensor?

      about 3 months ago
    • Marquis Jones
      Marquis Jones

      Dirty Throttle Body. Just happened to me on a 2016 chevy traverse

      about 3 months ago
    • Hose2wAcKiEr
      Hose2wAcKiEr

      I'm working with a 2011 Terrain. Low powered mode within 20 seconds of driving. Happened first time as I was going 70 down the highway. Almost got rear ended.

      Took it to the GM dealer. Fuel pressure sensor replacement and throttle body cleaning are recommended. I can clean the throttle body. But don't have the tools to change the sensor myself.

      They're quoting $1000 for the sensor replacement. I feel pretty screwed because if I had access to my cousins garage it could be a 1 hour $100 fix.

      Thanks for your vid

      about 3 months ago
    • adolfo puente
      adolfo puente

      ive had the same problem with my avalanche. i had taken it to different mechanics and nobody can find the problem. i changed the gas peddal, throttle body, the computer and crank shaft sensor and nothing. i happens aster i wash the truck

      about 3 months ago
    • ts6034
      ts6034 In reply to adolfo puente

      Check the wiring harness to the throttle body. Wiggle it and see if you can get it to mess up. They're common faults.

      about 3 months ago
    • robert cantonwine
      robert cantonwine

      ts6034.....thanks for the video. Would this apply to a 2008 GMC Acadia too ? I bought this vehicle used and the guy was honest with me and let me know he has issues with the traction control and dealerships can't figure anything out but just keep charging him for looking at it. I have had the service stabilitrak come on but have never had it say Reduced engine power until this past week when it got extrememly cold out. It comes on everyday now and I have to pull over and let it set and then it will start and drive like nothing ever happened. Does all this apply to your video ??? THanks

      about 3 months ago
    • ts6034
      ts6034 In reply to robert cantonwine

      It does apply to your vehicle but I would first have it scanned to see what codes are present before diving into it.

      about 3 months ago
    • Angelo Jensen
      Angelo Jensen

      My job has several vehicles in its "fleet". One of them is doing this same issue. One of our guys says its the traction control module. I'm gonna do this fix first. All it will cost is my time and the cost of the kit. Less expensive then towing it to a shop and paying them to do the work. Let you know if it works.

      about 3 months ago
    • ahmed alzoubi
      ahmed alzoubi

      Hello brother i have a malibu 2013
      Today i got the same problem .. the car was fine till this ( check engine with downword arrow + traction cintrl lights went on )
      The code on dashboard is code 84
      And when i checked it on computer the engineer told me its from the fuel pump i bought a new one but still not solved i hope ur video helps me tomorrow .
      Appreciate ur help

      about 4 months ago
    • Magdiel Alvarez
      Magdiel Alvarez In reply to ahmed alzoubi

      Did you ever figure out was it was I been having the same exact problem with my 2013 Malibu Ltz they told me that I had to change my front fuel pump. So I paid Chevy to change the front fuel pump after doing so I picked up the car and it ran fine but after 20 min of running the car would just shut off there is no check engine light on what so ever took it back to Chevy now they are telling me its the Exhaust cam sensor that’s causing the car to shut of wile on red lights I don’t know what to do.... fuck Chevy I will never buy a Chevy ever again

      about 3 months ago
    • ts6034
      ts6034 In reply to ahmed alzoubi

      Thanks for watching and good luck! Let me know what the fix was, I’m curious.

      about 4 months ago
    • technically observant
      technically observant

      never mind all that foolishness .just put some cleaners in your gastank it will take care of all that gunk

      about 4 months ago
    • Carlos Fuentes
      Carlos Fuentes

      Mm

      about 4 months ago
    • muster seeds
      muster seeds

      this is a nice coaching watches and learn, thank you.

      about 4 months ago
    • Angel Rodriguez
      Angel Rodriguez

      I had that happen to my 08 GMC Acadia. I went to the junkyard got a used one cleaned it (sensor up cause it leaks through the butterfly), put it on and it worked fine for a week or so. I drove for 3 hours straight and it started hesitating on me. Like it would jerk amd struggle to stay at speed then rpms would drop low. My rpms go crazy i have to step on the gas just for it to pick up but i dont have engine power reduced showing. Can you help with this

      about 4 months ago
    • Shandon Sims
      Shandon Sims

      If you know guys like this on good terms you're lucky, forget a car mechanic shop.

      about 4 months ago
    • Easy Fix
      Easy Fix

      I love your channel man!!🔧🔧

      about 4 months ago
    • ts6034
      ts6034 In reply to Easy Fix

      Thanks! Right back at you!

      about 3 months ago
    • Nevado Foster
      Nevado Foster

      Really good job, keep it up

      about 4 months ago
    • ts6034
      ts6034 In reply to Nevado Foster

      Thanks for the feedback!

      about 4 months ago
    • John T
      John T

      On a scanner, can you just clear the code after repair?

      about 4 months ago
    • ts6034
      ts6034 In reply to John T

      Yes as long as the fault is fixed.

      about 4 months ago