If your TL is killing the battery after sitting for a couple days, here is how to fix it. :)

Comments

    • Bimer catracho
      Bimer catracho

      So you looked up a video of this problem on YouTube and then made a video of you fixing the problem correct?

      about 10 days ago
    • Eric TK
      Eric TK In reply to Bimer catracho

      What? I had this problem with my car, so I fixed it and recorded it to help others.

      about 10 days ago
    • Apex Health and Fitness
      Apex Health and Fitness

      Thanks soooo much. I’ve been boosting my car for months. And 2 mechanics couldn’t find the problem. What a simple fix for something that stopped working a while ago

      about 1 month ago
    • MrDave 777
      MrDave 777

      Hello. I disconnected this on my 06. Question I have, why does my battery drain within an hour just listening to music? It's a new battery!

      about 1 month ago
    • MrDave 777
      MrDave 777 In reply to MrDave 777

      +Eric TK Terrific information! Thx. Great point.

      about 1 month ago
    • Eric TK
      Eric TK In reply to MrDave 777

      Speakers and amps use a large amount of power, and these cars have a factory subwoofer that uses even more. I guess it depends on the volume level, and type of music.

      about 1 month ago
    • Arnold Orpilla Jr
      Arnold Orpilla Jr

      Damn I wish I seen this 3 -4 years ago. I probably bought 3-4 batteries in that time. and why the fck hasn’t Acura stepped up and made this a defective product.

      about 2 months ago
    • Matt Hicklin
      Matt Hicklin

      *So they will make a truck... That's good. For some time now I've been figuring "If Tesla really wants to make money, they'll make a viable ( **lovy.biz/44oi** )1/2-ton LUV fleet-truck.". And they plan to make Class-8 semi-tractors & buses as well? Makes me look forward to the first luxury EV motor-home, built with fixed roof-top & retractable solar panels, all powering the EM-induction cook-top, water-heater & washer/clothes-dryer. Add a water collection system with reverse-osmosis treatment & UV-sterilizing, and you'll be set to survive anywhere, anytime!*

      about 2 months ago
    • Alex Church Church
      Alex Church Church In reply to Matt Hicklin

      super

      about 2 months ago
    • JaegerWrenching
      JaegerWrenching

      I chased the draw down to the interior fuse named interior lighting, can't believe this is on the same circuit as that and is my problem as well. GJ Acura, might as well power the heated seats with that same circuit while you're at it! Thank you for the fix Eric TK!

      about 3 months ago
    • Bill Graham
      Bill Graham

      Awesome, thank you so much, saved me big bucks!

      about 3 months ago
    • Nick rated
      Nick rated

      Thanks bro I'm about try that now

      about 4 months ago
    • Redwood Giant
      Redwood Giant

      Thank you so much

      about 4 months ago
    • Angelo Moreno
      Angelo Moreno

      Does the lights n radio still turn on before u removed it?

      about 4 months ago
    • Danielle
      Danielle

      Thank you!!

      about 4 months ago
    • Pragash Gnana
      Pragash Gnana

      How about while I'm driving the power shuts off

      about 5 months ago
    • Eric TK
      Eric TK In reply to Pragash Gnana

      That is something else all together. I would start with having the battery and battery connections checked, along with the alternator. AutoZone will do all these for free. Good luck!

      about 5 months ago
    • fillsgarage
      fillsgarage

      Were you able to recharge the battery or did you have to replace it?

      about 6 months ago
    • Eric TK
      Eric TK In reply to fillsgarage

      I charged it, and it worked perfectly.

      about 6 months ago
    • fillsgarage
      fillsgarage

      Great video thank you. My 08 TL is doing the same thing. What a silly oversight by Acura

      about 6 months ago
    • oscar orozco
      oscar orozco

      I had to jumpstart my car almost every day never knowing what the issue was and it turns out the issue was just this damn feature I don’t even use

      about 6 months ago
    • randomNpointless
      randomNpointless

      Thank you so much. This had been happening on my 2008 TL - Type S for a while, I even changed the battery a few times but same result, I couldn't leave the car off for a day without the battery dying. I disconnected it and left my car off for 3 days to test it out, and I was so happy when it turned on.

      about 6 months ago
    • Yousifian Nation
      Yousifian Nation

      Okay I see you with the 6speed. I have a ua7 6speed. Awesome cars

      about 6 months ago
    • Yousifian Nation
      Yousifian Nation

      You mean 04-08 tl

      about 6 months ago
    • Mingtenance
      Mingtenance

      I had the same issue on my 08 RDX. Disconnecting the HFL module dropped a drawing current down from 0.74 to 0.01A. I cannot believe this unreliable device is equipped on all Acura TL, TSX, RDX, MDX for those years. It is not only under-utilized but also causes another problem. What a piece of junk!

      about 7 months ago
    • Nick Violanti
      Nick Violanti

      Thanks Eric, I've had that issue for some time now with my 2006 tl. Gonna give that a go tomorrow.

      about 7 months ago
    • wes langdon
      wes langdon

      just unplugged mine hope this solves the issue, I saw another video with a guy that had the same issue, he said that even after he pulled the HFL he had a dead battery shortly after, went and had the battery checked (only 6 months old) at autozone they said the battery showed "bad battery" so he replaced it and it has been fine ever since. So for some of those commenting that it didn't fix the problem have your battery checked again.

      about 7 months ago
    • Dee laur
      Dee laur

      What tool do you need for this?

      about 8 months ago
    • Serenity Yang
      Serenity Yang

      My HFL works but still draining battery, is possible?

      about 8 months ago
    • Serenity Yang
      Serenity Yang In reply to Serenity Yang

      got it fixed, unplugged it and it's good now. Thank you very much.

      about 8 months ago
    • Eric TK
      Eric TK In reply to Serenity Yang

      Unplug it, and see if the battery still drains.

      about 8 months ago
    • komelion
      komelion

      Erik, Thanks so much for doing this video. You saved me and countless other people some good money and a ton of frustration. I can't tell you how many times I've had to get my car jumped. Probably close to 20! So 4 years, two batteries and an alternator later, the nightmare is over. Thanks again!!

      about 9 months ago
    • CheaperEngineer
      CheaperEngineer

      Thank you so much for posting! Did you notice any error messages or codes on the MID after disconnecting?

      about 9 months ago
    • Eric TK
      Eric TK In reply to CheaperEngineer

      I did not.

      about 9 months ago
    • Andres Urquizo
      Andres Urquizo

      Bless your soul

      about 9 months ago
    • Marc G
      Marc G

      Got it thanks alot tired of recharging my battery great video

      about 9 months ago
    • Marc G
      Marc G

      I just unplugged the handsfree I didn't remove anything

      about 9 months ago
    • Tessa Smith
      Tessa Smith In reply to Marc G

      Marc G how do u do that?

      about 6 months ago
    • Marc G
      Marc G

      Do your dome lights still work mine don't

      about 9 months ago
    • Eric TK
      Eric TK In reply to Marc G

      Marc G
      Mine still work, maybe check the bulbs or fuse.

      about 9 months ago
    • John Faieta
      John Faieta

      This video should be required watching before anyone can post on YouTube. Well done!

      about 10 months ago